智能交易网,程序化交易,自动交易,量化交易

 找回密码
 注册

QQ登录

只需一步,快速开始

手机短信登录

参加MT4智能交易编程培训,7课免费在线试听MT4指标,EA代写,或EA指标加密账户远程验证服务 最完善商业MT4跟单系统(0.1秒极速响应不漏单)为论坛做贡献有奖学金,奖学金可直接换真钱
扫本站微信公 众号部分视频课程指标EA免费得智能交易网MT4操盘神器,扫公众号免费得苏城码APP 
查看: 1331|回复: 2

求助老師: 想將通達信牛熊副圖改成 MT4 thanks

[复制链接]
发表于 2016-2-13 21:15:28 | 显示全部楼层 |阅读模式
A:=(CLOSE-LLV(LOW,32))/(HHV(HIGH,32)-LLV(LOW,32))*1.2*CLOSE;
B:=SMA(A,13,1);
中线:SMA(B,5.5,1.5),POINTDOT,LINETHICK3;
牛线:3*B-2*中线,COLORFFFFFF;
熊线:4*中线-3*B,COLORGREEN;
EMA牛线:EMA(牛线,10);
EMA牛线3:EMA(牛线,3);
EMA牛线4:EMA(牛线,5);
NX:=(3*CLOSE+LOW+OPEN+HIGH)/6;
牛线2:=(20*NX+19*REF(NX,1)+18*REF(NX,2)+17*REF(NX,3)+16*REF(NX,4)
+15*REF(NX,5)+14*REF(NX,6)+13*REF(NX,7)+12*REF(NX,8)+11*REF(NX,9)
+10*REF(NX,10)+9*REF(NX,11)+8*REF(NX,12)+7*REF(NX,13)+6*REF(NX,14)
+5*REF(NX,15)+4*REF(NX,16)+3*REF(NX,17)
+2*REF(NX,18)+REF(NX,20))/210;
牛熊线:=MA(牛线2,4);
DRAWICON(CROSS(牛线2,牛熊线),中线,32);
牛线1:=20*牛线+19*REF(牛线,1)+18*REF(牛线,2)+17*REF(牛线,3)+16*REF(牛线,4)
+15*REF(牛线,5)+14*REF(牛线,6)+13*REF(牛线,7)+12*REF(牛线,8)+11*REF(牛线,9)
+10*REF(牛线,10)+9*REF(牛线,11)+8*REF(牛线,12)+7*REF(牛线,13)+6*REF(牛线,14)
+5*REF(牛线,15)+4*REF(牛线,16)+3*REF(牛线,17)
+2*REF(牛线,18)+REF(牛线,20);
EMA牛线1:=EMA(牛线1,10);
DRAWICON(CROSS(牛线1,EMA牛线1),中线,33);

DRAWICON(CROSS(牛线,REF(EMA牛线,1)),EMA牛线,1);


DRAWICON(CROSS(EMA牛线,牛线),EMA牛线,2);
DRAWICON(CROSS(EMA牛线3,EMA牛线4),EMA牛线,1);
DRAWICON(CROSS(EMA牛线4,EMA牛线3),EMA牛线,2);
MAVOL5:MA(VOL,6),NODRAW;
DRAWICON(VOL>=MAVOL5*3.3 ,中线,30);
DRAWICON(VOL>MAVOL5*1.9 AND VOL<MAVOL5*3.3 ,中线,41);

DRAWICON(VOL<=MAVOL5*0.3 ,中线,18);
DRAWICON(VOL<=MAVOL5*0.5 AND VOL>MAVOL5*0.3 ,中线,9);


DRAWICON(REF(O,1)>REF(C,1) AND C>O AND REF(VOL,1)<VOL ,中线,38);
DRAWICON(REF(O,1)<REF(C,1) AND C<O AND REF(VOL,1)<VOL ,中线,39);
DRAWICON(REF(O,4)>REF(C,4) AND REF(O,3)>REF(C,3) AND REF(O,2)>REF(C,2) AND REF(O,1)>REF(C,1) AND O>C ,中线,23);

IF(中线<=REF(中线,1),中线,DRAWNULL),POINTDOT,COLORGREEN,LINETHICK5;
IF(牛线>=REF(牛线,1),牛线,DRAWNULL),COLORRED,LINETHICK1;
IF(牛线>=REF(牛线,1),牛线,DRAWNULL),POINTDOT,COLORRED,LINETHICK5;


A1:=(C+O)/2,NODRAW;
IF(熊线<=REF(熊线,1),熊线,DRAWNULL),COLORWHITE,LINETHICK1;
IF(熊线<=REF(熊线,1),熊线,DRAWNULL),POINTDOT,COLORWHITE,LINETHICK5;
DRAWICON(A1>=REF(A1,1) AND VOL>REF(VOL,1) AND C>O AND 牛线>熊线,熊线*0.9,34);
DRAWICON(A1>REF(A1,1) AND 牛线<熊线,熊线*1.1,36);
DRAWICON(A1<REF(A1,1) AND 牛线<熊线,熊线*1.1,37);
DRAWICON(A1>=REF(A1,1) AND VOL>REF(VOL,1) AND REF(C,1)<REF(O,1) AND C>O AND 牛线<熊线,熊线*1.1,34);
DRAWICON(A1>REF(A1,1) AND 牛线>熊线,熊线*0.9,36);
DRAWICON(A1<REF(A1,1) AND 牛线>熊线,熊线*0.9,37);




NEXTLOW1:REF(L,1)-L,LINETHICK1,NODRAW;
NEXTH1:H-REF(H,1),LINETHICK1,NODRAW;
VAR1:=(C+H+O+L)/4,NODRAW;
卖出:XMA(VAR1,20)*(1+80/1000),COLORGREEN,LINETHICK1,NODRAW;
买入:XMA(VAR1,30)*(1-100/1000),COLORMAGENTA,LINETHICK1,NODRAW;


IF(NEXTLOW1<=REF(NEXTLOW1,1) AND L<=买入,中线,DRAWNULL),POINTDOT,COLORMAGENTA,LINETHICK5;
IF(NEXTH1>=REF(NEXTH1,1) AND H>=卖出,中线,DRAWNULL),POINTDOT,COLORGREEN,LINETHICK5;

MA3:EMA(A1,3),NODRAW;
MA4:EMA(A1,4),NODRAW;
IF(CROSS(MA3,MA4) AND MA3>MA4,牛线,DRAWNULL),POINTDOT,COLORMAGENTA,LINETHICK5;
IF(CROSS(MA4,MA3) AND MA3<MA4,牛线,DRAWNULL),POINTDOT,COLORGREEN,LINETHICK5;

回复

使用道具 举报

 楼主| 发表于 2016-2-13 21:19:19 | 显示全部楼层
另一個同花順改寫mt4 也可 超級感謝~~:

A:=(CLOSE-LLV(LOW,32))/(HHV(HIGH,32)-LLV(LOW,32))*1.2*CLOSE;
B:=SMA(A,13,1);
中线:SMA(B,5.5,1.5),POINTDOT,LINETHICK3;
牛线:3*B-2*中线,COLORFFFFFF;
熊线:4*中线-3*B,colorgreen;

EMA牛线:EMA(牛线,10);
EMA牛线1:EMA(牛线,3);
EMA牛线2:EMA(牛线,2);
DRAWICON(牛线>=REF(牛线,1) OR CROSS(牛线,ema牛线),牛线,1);
DRAWICON(牛线<=REF(牛线,1) OR CROSS(ema牛线,牛线),熊线,2);
DRAWICON(CROSS(ema牛线2,EMA牛线1),中线,1);
DRAWICON(CROSS(ema牛线1,EMA牛线2),中线,2);

IF(中线<=REF(中线,1),中线,DRAWNULL),POINTDOT,colorgreen,LINETHICK5;
IF(牛线>=REF(牛线,1),牛线,DRAWNULL),colorred,LINETHICK1;
IF(牛线>=REF(牛线,1),牛线,DRAWNULL),POINTDOT,colorred,LINETHICK5;


A1:=(C+O)/2,NODRAW;
IF(熊线<=REF(熊线,1),熊线,DRAWNULL),colorwhite,LINETHICK1;
IF(熊线<=REF(熊线,1),熊线,DRAWNULL),POINTDOT,colorwhite,LINETHICK5;
DRAWICON(A1>=REF(A1,1) AND VOL>REF(VOL,1) AND C>O AND 牛线>熊线,熊线*0.9,34);
DRAWICON(A1>REF(A1,1) AND 牛线<熊线,熊线*1.1,36);
DRAWICON(A1<REF(A1,1) AND 牛线<熊线,熊线*1.1,37);
DRAWICON(A1>=REF(A1,1) AND VOL>REF(VOL,1) AND REF(C,1)<REF(O,1) AND C>O AND 牛线<熊线,熊线*1.1,34);
DRAWICON(A1>REF(A1,1) AND 牛线>熊线,熊线*0.9,36);
DRAWICON(A1<REF(A1,1) AND 牛线>熊线,熊线*0.9,37);


回复 支持 反对

使用道具 举报

发表于 2016-5-29 20:07:50 | 显示全部楼层
唉,还是2月份的
回复 支持 反对

使用道具 举报

您需要登录后才可以回帖 登录 | 注册

本版积分规则

小黑屋|手机版|sitemap| 智能交易网,程序化交易,自动交易,量化交易 ( 苏ICP备08108698号,苏州智德金网络科技股份有限公司版权所有 )

GMT+8, 2020-6-4 07:30 , Processed in 0.082233 second(s), 15 queries , Gzip On.

Powered by Discuz! X3.4

© 2001-2017 Comsenz Inc.

快速回复 返回顶部 返回列表